John Davidson

Laravel 5.8 running on PHP 8.0


I have issue now

Updating dependencies                                                                                                                                                                                     
Your requirements could not be resolved to an installable set of packages.

Problem 1
- laravel/framework[v5.8.0, ..., 5.8.x-dev] require php ^7.1.3 -> your php version (8.0.10) does not satisfy that requirement.
- Root composer.json requires laravel/framework 5.8.* -> satisfiable by laravel/framework[v5.8.0, ..., 5.8.x-dev].

I tried add this already

"php": "^7.1.3|^8.0",

What do I do now? I upgraded my local PHP to 8.0 today.

My Answer:
This issue is occurring because Laravel 5.8 requires PHP version 7.1.3 or higher, but you are trying to run it on PHP 8.0 which is not compatible with Laravel 5.8.

To resolve this issue, you have a few options:

1. Downgrade your PHP version to 7.1.3 or higher: You can downgrade your PHP version to a compatible version with Laravel 5.8. This will allow you to run Laravel 5.8 without any compatibility issues.

2. Upgrade Laravel to a version that is compatible with PHP 8.0: If you want to continue using PHP 8.0, you can upgrade your Laravel application to a version that is compatible with PHP 8.0. Laravel 6.x and above are compatible with PHP 8.0, so you can consider upgrading your Laravel application to a newer version.

3. Use a different Laravel version: If downgrading or upgrading Laravel is not an option for you, you can consider using a different version of Laravel that is compatible with your current PHP version.

Choose the option that best fits your requirements and make the necessary changes to resolve the issue.

Rate this post

3 of 5 based on 7667 votes


© 2024 - Personal Blogs Platform. All Rights Reserved.
Create blog  |  Privacy Policy  |  Terms & Conditions  |  Contact Us